Fork me on GitHub

Library - OverView

#OverView

The CL framework's Library has a few system requirements.

You will need to make sure that your server meets the following requirements:

  • PHP >= 7.0.0
  • GD PHP Extension

Step 01. Update a compose.json file called `composer.json`


{
    "require": {
        "php": ">=7.0",
        "cafelatte/framework": "v1.0.*",
         "cafelatte/library": "v1.0.*"
    }
}

To install library, add a yellow color line

Step 02. Update a Config File


{
  "server_name": "TEST SERVER",
  "server_type": "develop",
  "project": {
    "name": "hello world project",
    "path": "/home/projects/my_project/",
    "version": "0.1.1",
    "url": "http://localhost",
    "security_level": "normal"
  },
  "log": {
    "level": "debug",
    "path": "/home/projects/my_project/logs/"
  },
  "template": {
    "input": "",
    "output": "",
    "user": "",
    "group": ""
  },
  "upload": {
    "path": "/home/projects/upload_folder_full_path/"
  },
  "config": {
    "key1": "value1",
    "key2": "value2",
    "key3": "value3",
    "key4": "value4"
  }
}


in order to upload files to server, add a yellow color line on configure file